Metrc Latency
Incident Report for Greenbits
Resolved
Metrc has completed their routine maintenance and all services are operational.
Posted Nov 08, 2024 - 07:13 PST
Investigating
We are observing increased latency and timeouts in METRC for multiple states. We have contacted METRC and the ticket number is 02223590.
Posted Nov 07, 2024 - 21:58 PST
This incident affected: Traceability (Metrc Colorado, Metrc Oregon).