Errors in METRC Michigan

Incident Report for Greenbits

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 07:50 PDT

Investigating

We are currently working with the Metrc Support team regarding errors observed by our Metrc Michigan customers. Metrc Ticket - 02263040
Posted Mar 20, 2025 - 06:33 PDT
This incident affected: Traceability (Metrc Michigan).